1. Home
  2. Knowledge Base
  3. GeoHECRAS
  4. Viewing Stage and Flow Hydrographs

Viewing Stage and Flow Hydrographs

The GeoHECRAS software can generate stage and flow hydrographs of the HEC‑RAS unsteady flow computational results for various node types such as Bridges/Culverts, Inline Structures, Lateral Structures, and Storage Areas. In addition, the hydrographs can be copied to the Windows clipboard and printed for later use.

Displaying Stage and Flow Hydrographs

If the user has performed an unsteady flow analysis, then stage and flow hydrographs will be available for viewing.

To view a stage and/or flow hydrograph, follow these steps:

  1. From the Results ribbon menu, expand the Time Series Plots dropdown combo box and choose the Stage & Flow Hydrographs command.
    Stage and Flow Hydrographs command
  2. The Stage and Flow Hydrographs dialog box will be displayed.
    Stage and Flow Hydrographs dialog box

Selecting River Reach

For an HEC‑RAS model with multiple river reaches, the user can select one or more river reaches to plot. The River and Reach dropdown combo boxes display a listing of the river and corresponding reaches contained within the model. The user can select the preferred river reach using these dropdown combo boxes.
River and Reach dropdowns

Selecting River Station

The River Station (River Sta.) dropdown combo box displays a listing of all the river stations contained within the selected reach. The user can select the river station to plot the hydrograph. To move to the next downstream river station, click the [↓] button. To move upstream, click the [↑] button.
River Station (River Sta.) dropdown

Selecting Node Type

The Type menu of the Stage and Flow Hydrograph dialog box allows the user to select the specific node type to be viewed.
Type menuBy default, the plot comes up with a node type of cross section selected. This allows the user to view hydrographs at cross sections only.

Other available node types include:

  • Bridges/Culverts
  • Inline Structures
  • Lateral Structures
  • Storage Areas
  • SA/2D Connections
  • Pump Stations
  • Ground Water Interaction
  • SA/2D Flow Area – BCLines

Stage and Flow Hydrograph Plot Options

The Stage and Flow Hydrographs dialog box provides several options for changing the viewpoint of the stage and flow hydrographs. The Plot Stage and Plot Flow checkboxes allows the user to plot the stage and flow hydrograph, respectively. The user can check both the checkboxes to plot both the hydrographs simultaneously. Checking the Obs Stage and Obs Flow checkboxes allows the user to plot the observed stage and flow hydrograph data at locations where gaged information is stored in a DSS file. The Use Ref Stage checkbox can be checked to plot the stage hydrograph using a reference stage.
Stage and flow hydrographs plot options

The user can switch between three tabbed panels: Stage Flow, Table and Rating Curve to view the graphical plot, data in tabular form or the rating curve plot of the event. Additionally, the dialog box also provides statistics about the hydrograph plots in a tabular form. The table’s Maximum, Time at Max and Volume (acre-ft) columns shows the peak stage and flow, and time of peak and volume, respectively.
Stage Flow, Table and Rating Curve panels

Graphical Plot Options

The Options menu of the Stage and Flow Hydrographs dialog box provides several plotting features for viewing the graphical plots.
Options menuThe below sections describe how to use each of the above shown plotting features.

Zoom In

This option allows the user to zoom in on a portion of the graphic plot. The user can select the Zoom In command from the Options menu and specify the area to zoom in with the mouse.

To define the zoom area, the user can place the mouse pointer at a corner of the desired zoom area. Then the user can press and hold the mouse button and drag the mouse to define a box containing the desired zoom area.
Zoom In commandOn releasing the mouse button, the viewing area will display the zoomed-in graphic plot. A small window showing the entire plot will be placed in one of the corners of the plotting area. This window is called the Zoom Window. The Zoom Window shows the entire graphic plot with a box around the zoomed in area. The user can move the zoom box or resize it to change the viewing area.
Zoom Window

Zoom Out

Selecting the Zoom Out option causes the software to double the size of the currently zoomed in graphic plot.

Full Plot

Selecting the Full Plot option causes the software to re-display the graphic plot at its original size.

Pan

This option allows the user to move the graphic plot around. After selecting the Pan option, the user can press and hold the mouse button over the graphic plot, then move the graphic plot in the desired direction. Alternatively, the user can hold down the [Shift] key to put the pointer into the Pan mode. Releasing the [Shift] key turns the Pan mode off.

Animate

This option is generally used for unsteady flow output analysis but can also be used for steady flow output. This option works with the cross section, profile, and X, Y, Z perspective plots. To learn more about the Animate option, refer to this article in our knowledge base.

Plans

This option allows the user to select from the available plans (Scenarios) for plotting. The default plan is the currently opened plan. The user can select additional plans to compare results graphically.
Plan Selection dialog box

View Interpolated XS’s

This option allows the user to view the interpolated cross sections. To learn how to interpolate cross sections, refer to this article in our knowledge base.

Number of Decimal Places

This option allows the user to define the number of decimal places for the flow and hydrograph table. Selecting the Number of Decimal Places option will display the RAS dialog box where the user can enter the value (between 0 and 9) to define the number of decimal places.
RAS dialog box for entering decimal places

Lines and Symbols

This option allows the user to customize the line types, line colors, line widths, symbol types, symbol sizes, symbol colors, fill patterns, and line labels. To learn more about the Lines and Symbols option, refer to this article in our knowledge base.

Scaling

The Set Temporary Scale and Set Persistent Scale options allow the user to define the scaling used for the plot. The user can set the minimum, maximum, and labeling increment for the X and Y axis. Scaling can be set temporarily, or to be persistent (scaling stays constant for all river stations). Persistent scaling is only available for the cross section and rating curve plots. Selecting either of the options will display the HEC-RAS dialog box where the user can enter the scaling factor for minimum, maximum and labeling increment values for the X and Y axis.
HEC-RAS dialog box for entering scale factors

Grid

This option allows the user to overlay a grid on top of the graphic plot. Selecting the Grid option will display the HEC-RAS dialog box where users can check the desired checkboxes to display both major and minor tics as well as borders around the plot.
HEC-RAS dialog box for displaying grid lines

Zoom Window Location

This option allows the user to control the placement and size of the Zoom Window. Selecting the Zoom Window Locations option will display the Zoom Window Location and Size dialog box. In this dialog box, the user can select the corner where the Zoom Window will be displayed as well as enter the height and width for the Zoom Window.
Zoom Window Location and Size dialog box

Font Sizes

This option allows the user to control the size of all of the text displayed on the graphic. Selecting the Font Sizes option will display the Graphics Font Point Sizes dialog box. In this dialog box, the user can define text size for captions, legend, axis labels and titles, Manning’s n and Reach labels.
Graphics Font Point Sizes dialog box

View List of DSS Paths

This option allows the user to view the DSS file paths used to define the unsteady flow data. Selecting the View List of DSS Paths option will display the List of paths in the flow and stage editor dialog box that lists the DSS pathnames along with DSS file location.
List of paths in the flow and stage editor dialog box

Sending Graphics to the Windows Clipboard

The user can send the graphic plot to the Windows clipboard. Moving a graphic to the clipboard allows that graphic to then be pasted into another piece of software (i.e., a word processor or another graphics program).

To transfer the graphic plot to the Windows clipboard, the user can select the Copy to Clipboard command from the File menu. The graphic plot will automatically be sent to the Windows clipboard.
Copy to Clipboard command

Printing Graphic Plot

The software also allows the user to send the graphical plots directly to a printer. Selecting the Print command from the File menu will display the Print Options dialog box. This dialog box allows the user to modify the default print options. After selecting the desired options, the user can click the [Print] button. The graphic plot will be sent to the Windows print manager. The print manager will then send the plot to the default printer.
Print Options dialog box

The software also allows the user to print multiple graphic plots at one time. Selecting the Print Multiple command from the File menu will display the Multiple Location Print – Select Locations dialog box. In this dialog box, the user can select the node type and the corresponding river stations whose stage and flow hydrographs are to be printed.
Multiple Location Print - Select Locations dialog box

About the Author Chris Maeder

Was this article helpful?

Related Articles