1. Home
  2. Knowledge Base
  3. Importing Data
  4. Importing MicroStation Terrain Surfaces
  1. Home
  2. Knowledge Base
  3. MicroStation Drawings
  4. Importing MicroStation Terrain Surfaces

Importing MicroStation Terrain Surfaces

With so many civil engineering software applications available, each with their own proprietary database structures, data interoperability has become a major problem. Over time, engineering consultants and review agencies called upon the industry to develop a standard design data format that would allow quick and easy data exchange capability from one software application to another. In 2000, LandXML.org, led by an industry-driven consortium of partners, came forward to provide a non-proprietary data exchange standard called LandXML.

CivilGEO’s software utilizes LandXML to share data with many other civil engineering software programs, such as:

  • AutoCAD Civil 3D
  • Bentley MicroStation
  • Carlson Civil Suite
  • And others…

What is LandXML?

LandXML is a file format that has been developed as an industry standard for civil engineering, land planning, and surveying software. This open data file format is readable by various applications. Because of its non-proprietary nature, LandXML files can be easily imported and exported from one application to another, without relying on any specific vendor and their programs.

Using LandXML, you can transfer data from one application to another, archive the project data in a non-proprietary format, view, edit, and report data using web-based tools, as well as adjust the elevation of the data globally.

However, when you are exporting or importing data in the LandXML format, keep in mind that you won’t get data in a “ready to go” condition; you have to carefully incorporate drawing information and other features by taking reference from the original drawing. You must also make sure that the software version of LandXML is compatible while importing and exporting.

Importing MicroStation Surfaces using LandXML

When you are working on MicroStation, specifically OpenRoads, MX Roads, InRoads, and GEOPAK, you can import its surfaces into CivilGEO’s software using the LandXML format. Our software fully supports LandXML files and importing this format into the software is a quick and easy process. Importing MicroStation surface into the software is a two-step process: first exporting the surface into LandXML file format, and then importing it into the software.

Below are the steps described for importing various MicroStation Surfaces into the software.

Importing Terrain Surface from MX Roads

To import terrain surfaces from Bentley MX Roads, you must first export the surface to LandXML format. To export the data to a LandXML file, follow these steps:

  1. Open the project in MicroStation with the terrain surfaces you want to export.
  2. Select File > Export > LandXML… to export the LandXML file.

After exporting the terrain surface as a LandXML file, you can import it into CivilGEO’s software. Refer to this knowledge base article on how to import a LandXML terrain surface file into CivilGEO’s software.

Importing Terrain Surfaces from InRoads

To import terrain surfaces from Bentley InRoads, you must first export the surface to LandXML format. Make sure to model your road before exporting. Further, there are two types of design data that you can export from InRoads: Terrain Surface Data and Geometry Data. Also, there is no default setting for exporting surfaces to LandXML. You have to turn on the feature by following these steps:

  1. Go to the InRoads main menu, select Tools > Application Add-ins.
  2. From the drop-down list, ensure that XML Report Add-In is checked on.
  3. Click the [OK] button.

Then you can proceed to export design data according to your requirement.

Export Terrain Surface from InRoads

Follow these steps to export the terrain surface as a LandXML:

  1. From the InRoads main menu, select File > Translators > LandXML Translator. The LandXML dialog box will be displayed.
  2. In the LandXML dialog box, click on the Export Surface tab.
  3. In the Surfaces area, select the surfaces to be exported.
  4. According to your requirement, select the checkbox options for Include Triangles, Include Features, and Include Non Triangulated Features.
  5. Go to the Linear Units drop-down combo box and select US feet.
  6. From the State drop-down combo box, select proposed or existing to match the surface being exported.
  7. Click on Save As. The Save As dialog box will appear.
  8. Click on the Change… button and browse to the directory where file should be saved.
  9. Fill the relevant details in appropriate fields for Name, File Name, and Description.
  10. Click the Save button.

After exporting the terrain surface as a LandXML file, you can import it into CivilGEO’s software. Refer to this knowledge base article on how to import a LandXML terrain surface file into CivilGEO’s software.

Export Geometry Data from InRoads

Follow these steps to export the geometry or alignment data as a LandXML file:

  1. From the InRoads main menu, select File > Translators > LandXML Translator. The LandXML dialog box will be displayed.
  2. In the LandXML dialog box, select the Export Alignment tab.
  3. In the Alignment Data area, select the Geometry Project you wish to export.
  4. In the Include field, fill in the desired alignment. You can select multiple alignments by using the target button. Please note that you must make the desired vertical alignment active before exporting the file.
  5. Select the radio button beside the LandXML version you want your data to be saved as.
  6. Check the box beside Include Active Children Only.
    • If checked, it will only include the vertical alignment that is active.
    • If unchecked, it will include data for all the vertical alignments under the selected horizontal alignment.
  7. Select the checkbox option Include All Cogo Points. If checked, it will include all the COGO points in the buffer area. If unchecked, it will only include the points associated with the selected alignment.
  8. From the Linear Units drop-down combo box, choose US Feet.
  9. From the State drop-down combo box, choose proposed or existing to match the alignment being exported.
  10. Click on Save As. This will display the Save As dialog box.
  11. Click on the Change… button and browse to the directory where the file should be saved.
  12. Fill the relevant details in appropriate fields for Name, File Name, and Description.
  13. Click the Save button.

After exporting the data as a LandXML file, you can import it into CivilGEO’s software. Refer to this knowledge base article on how to import a LandXML terrain surface file into CivilGEO’s software.

Importing Terrain Surfaces from GEOPAK

To import terrain surfaces from Bentley GEOPAK, you must first export the surface to LandXML format. You have the option to export design data of two types: DTM (terrain surface) and Geometry Data.

Export Terrain Surface (DTM) from GEOPAK

If your DTM is in a TIN format, you can directly export the DTM to a LandXML file. Otherwise, you will need to create a TIN before exporting.

Follow these steps:

  1. From the GEOPAK Applications menu, choose GEOPAK ROAD and select DTM Tools.
  2. From the menu bar, select DTM Menu.
  3. From the DTM menu, open the Utilities menu and select Export LandXML.
  4. The DTM Export LandXML dialog box will appear.
  5. In the dialog box, fill the relevant details in appropriate fields:
    • TIN File: Click the magnifying glass to browse to the TIN to be exported.
    • Project Name: Enter a Project Name and Description. It should be Complete 11-digit FPID#. Remember that this name will be further exported to the LandXML file.
    • Description: SR#
    • English Unit: Options are available for US Survey Feet and International feet.
    • LandXML File: Browse to the location and name the LandXML file to be exported. Make sure to follow the naming conventions: DTM_LandXML.xml.
  6. Then click on Export.

After exporting the terrain surface as a LandXML file, you can import it into CivilGEO’s software. Refer to this knowledge base article on how to import a LandXML terrain surface file into CivilGEO’s software.

Export Geometry Data from GEOPAK

Follow these steps to export the geometry data as a LandXML file:

  1. Open the GEOPAK Coordinate Geometry dialog, then select File > Export > LandXML 1.0 Geometry.
  2. The Export LandXML 1.0 dialog box will appear.
  3. In the dialog box, fill in the relevant details:
    • Project Name: Complete 11-digit FPID#
    • Description: SR#
    • LandXML File: Make sure to follow the naming conventions: POINTS_LandXML.xml
    • Output Mode: Create
    • English Unit: US Survey Point
    • Point: Select All
  4. Then, click on Export.

After exporting the data as a LandXML file, you can import it into CivilGEO’s software. Refer to this knowledge base article on how to import a LandXML terrain surface file into CivilGEO’s software.

If you need any assistance on importing MicroStation Surfaces into our engineering software, feel free to contact our technical support team. They will be glad to assist you.

About the Author Chris Maeder

Was this article helpful?

Related Articles